Jump to content

McWhitey

Newbie
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About McWhitey

  • Rank
    Newbie

General Info

  • Location
    Japan
  • Car Type
    Nissan Silvia
  • Car Model
    S15
  1. So I recently bought a stock Spec S and had a Sr20det out of another S15 swapped into it. It’s been having an issue stalling when warm. (One of many issues). Ex: pulling up to a stop light on flat ground when the cars been running for 20 minutes, I put the clutch down all the way, blip the gas to get the RPMs up and it will stall out before the revs move. Won’t start for a few minutes at most. when slowing to a stop in neutral or with the clutch down it stalls randomly, won’t start for upwards to 5 minutes When the car is warm and I park it for more than 5 minutes, I’ll come back and it will turn over and then stall almost instantly. The previous owner of the engine just happened to have the same mechanic I have. I was informed that they installed a second coolant temp sensor in the dash with a toggle switch, when the car wouldn’t start he would flip to the in dash sensor and it would start. Mechanic said the CAS tested just fine, still don’t know what caused the cam damage. Car at has a straight pipe exhaust and constantly backfired on daily driving, and smelt extremely rich(I know...no CAT) so my though was instantly CAS, perhaps the mechanic didn’t test it properly? Also: found metal in the oil, opened the valve cover and the intake cam was scratched bad. Got Poncam’s being installed now along with a brand new Vct. Z32 MAF Front mount r32 fuel pump Any advice is much appreciated, been throwing so much money at a car I just wanted for a fun daily driver... A52D7969-1BC8-4238-B51C-DB58F36341E9.MOV 968C60A7-DC12-4628-8153-60C7C7A11509.MOV
×